2008-12-02

Usando modem huawei E226 - Claro 3G e outras!

Já possuo o modem da claro há cerca de um mês, neste período testei várias soluções para conectá-lo à internet, dentre estas:

1- wvdial, este programa é a base para a conexão 3G, EDGE e GPRS no Linux, pelo o que vi quase todos os outros programas carregam este em segundo plano.

2- pppconfig, kppp e gnome-ppp estes programas dão conta do serviço, contudo são limitados às mesmas funcionalidades do wvdial

3- network-manager do Ubuntu 8.10, quem já possui o intrepido, e um modem 3G/2G, com certeza já usou, bom cai no mesmo problema dos outros anteriores, destacando-se apenas o fato deste ter pré-configurado quase todas as operadoras do Brasil e do mundo, isso para usuários totalmente leigos é uma boa!

4- A melhor solução de todas é o vodafone-mobile-connect este programa feito em python resolve 5 (cinco) grandes problemas enfrentados por usuários 3G (versão 1.9.17 beta4 de 27/11/2008):



4.1- Interface gráfico com vários recurso, inclusive nível do sinal e modo de operação 3G/EDGE/GMS
4.2- Inteface para envio e recebimento de SMS.


4.3- Detecção do modelo do modem
4.4- Acaba com o problema do modem ficar sendo reconhecido como um storage. (pendrive ou gravadora)
4.5- Acaba com o problema de DNS da claro, mesmo aparcendo o IP errado no resolv.conf ele conecta na boa nos sites (ao menos aqui está funcionando bem).

O único recurso que este software não possui em relação ao similar para windows é a possibilidade de mudar a frequencia de operação, sei que é via algum comando AT que pode ser enviado diretamente à porta ttyUSB do modem, contudo não sei qual é. (se alguém souber avise!), isto é necessário para fazer o modo EDGE (2G/GSM) funcionar direito já que não conecta se estiver setado para as "todas as frequencias", devendo estar no modo 850,900,1800 e 2100MHz.

Além disso tive problemas com os pacotes que estão disponibilizados no site dos desenvolvedores:
Vodafone Mobile

Um dos pacote é para arquitetura LPIA (Low Power Intel Architecture) para processadores ATOM, e o outro tenta executar uns scripts incompatíveis com o Ubuntu 8.10, por esta razão fiz novas versões dos pacotes, para quem queira se aventurar:
usb-modeswitch_0.9.4-1_i386.deb
vodafone-mobile-connect_1.99.17-8_all.deb

Após baixar os pacotes acima, vá para a shell ou pelo nautilus mesmo e instale os programas se der erro de dependencias instale-as com o comando apt-get -f install e tente novamente.
Postar um comentário